设为首页收藏本站

LUPA开源社区

 找回密码
 注册
文章 帖子 博客
LUPA开源社区 首页 IT综合资讯 查看内容

Apple列出235个与macOS Catalina不兼容的应用

2019-10-14 09:20| 发布者: joejoe0332| 查看: 561| 评论: 0|原作者: oschina|来自: oschina

摘要: macOS Catalina 正式版已于上周发布,新版本带来了许多令人振奋的改进,不过兼容性方面的问题也“劝退”了部分原本计划升级的用户。从该版本开始,macOS Catalina(10.15)不再支持 32 位应用,这也是首个只支持 64 ...

macOS Catalina 正式版已于上周发布,新版本带来了许多令人振奋的改进,不过兼容性方面的问题也“劝退”了部分原本计划升级的用户。

从该版本开始,macOS Catalina(10.15)不再支持 32 位应用,这也是首个只支持 64 位应用程序的 macOS 版本,亦即意味着有数量相当可观的一批旧应用将不能在新系统中运行。

近日一名 iOS 开发者发现 macOS Catalina 内部一个名为 IncompatibleAppsList.bundle 的资源文件包列出了总计 235 个与 macOS Catalina 不兼容的应用列表,资源文件包的路径为/Library/Apple/Library/Bundles/

据介绍,这份列表用于在安装 Catalina 过程中向用户提醒不兼容新系统的已安装应用程序,下面是一个提醒示例:

Transmit: this version of Transmit is not compatible with this version of macOS. 

列举部分值得关注的应用:

  • Transmit 4.1.7
  • 1Password 2.12.2
  • iStats Menu 2.9
  • Box Sync 4.0
  • QuickBooks 2015
  • SugarSync 1.0
  • Default Folder X 4.3.10
  • VMWare Fusion 3.1.4
  • Creative Cloud 1.1.0.592
  • Parallels 2.5
  • ……

完整的列表请查看:https://gist.github.com/stevemoser/a4388df17633beae5bc3fb07d38373e2

到底要不要升级到新系统呢,事实上这个改动对于近两年才使用 Mac 的用户来说影响不大,毕竟 Apple 早已在 macOS 中全面推动开发者开发 64 位应用,但如果你是一名常年使用 Mac 的老用户,那么升级之前最好查一下应用的兼容性情况(尤其是 Adobe 系应用),方法如下:

打开「关于本机」> 在「概览」里选择「系统报告」> 选择「应用程序」> 点击应用即可查看。


酷毙

雷人

鲜花

鸡蛋

漂亮
  • 快毕业了,没工作经验,
    找份工作好难啊?
    赶紧去人才芯片公司磨练吧!!

最新评论

关于LUPA|人才芯片工程|人才招聘|LUPA认证|LUPA教育|LUPA开源社区 ( 浙B2-20090187  

返回顶部