设为首页收藏本站

LUPA开源社区

 找回密码
 注册
文章 帖子 博客
LUPA开源社区 首页 业界资讯 软件追踪 查看内容

Bash 5.0发布,部分功能与4.4不兼容

2019-1-10 11:10| 发布者: joejoe0332| 查看: 112| 评论: 0|原作者: oschina|来自: oschina

摘要: Unix Bash 放出第 5 个主要版本这个版本主要修复了Bash 4.4 中几个明显的错误,同时也加入了一些新功能。Bash 是一个完整的POSIX 规范项目,除了有交互式命令列编辑功能,还在基架构上支援工作控制,并提供类似csh的 ...

Unix Bash 放出第 5 个主要版本这个版本主要修复了Bash 4.4 中几个明显的错误,同时也加入了一些新功能。Bash 是一个完整的POSIX 规范项目,除了有交互式命令列编辑功能,还在基架构上支援工作控制,并提供类似csh的功能等。

Bash 5.0 主要解決 Bash 4.4的错误,改变对nameref解析的方法,和一系列以模糊测试发现的潜在查出范围的错误。另外,Bash 5.0 在不执行字符拆解以符合Posix标准解释的情況下,在不同的上下文中,$@和$*的擴充也有許多改變,而且還解決不少極端案例以增加Posix的一致性。

而本次最重要的功能更新,是增加了新的环境变量,BASH_ARGV0、EPOCHSECONDS和EPOCHREALTIME。而内建的 History 功能现在可以用来刪除历史数据的范围,并且将负的参数作为历史列表末端的偏移量。Bash 5.0还增加了一个选项,允许区域变量集成前一个作用域中,具有相同名称的变量名。

另外,还加入一个新的选项,启用后将允许 shell 只尝试 扩展开始下标(Subscripts)一次,但官方表示,这个功能在数学表达式中仍会出现使用问题。Bash 5.0现在会预设启用globasciiranges 选项,使用者可以在配置阶段將其设定为预设关闭。

官方提醒,Bash 4.4和Bash 5.0之間存在部分不兼容的更新,像是 nameref 解析方法的更新,代表着使用 namerefs 会出现不同的行为,尽管官方提到他们已经尽可能减少这种兼容性问题,但仍有部分无法避免。除此之外,现在在预设情况下,当启用扩充模式的时候, shell 才会启动配置BASH_ARGC和BASH_ARGV,官方表示,这是一个之前的设置定疏忽,在传递大量参数时,会造成效率低下的问题。

官方建议使用者可以将 Bash 连接到已安裝的 Readline 库,而非使用 lib/readline 中的版本,因为只有 Readline 8.0 以及以上版本,才能提供所有Bash 5.0需要的字符,使用早前的 Readline 库版本将无法正常运行。

升级至 Bash 5.0

  1. 检查现有的 bash 版本 bash --version

  2. 使用 brew 安装 bash brew install bash

由于 MacOS 禁止更改系统目录权限,并引入 sip 机制,所以需要先关闭sip,修改 bash 相关设置,再打开 sip 。

  1. 重启 MacOS ,开机时按住 Command+R

  2. 出现界面之后,选择 Utilities menu 中 Terminal 。

  3. 在Terminal 中输入 csrutil disable 关闭SIP。

  4. 重启 MacOS

  5. 加入软连接

sudo mv /bin/bash /bin/bash.origin 
sudo ln -s /usr/local/bin/bash /bin/bash

  1. 重启电脑,开机时按住 Command+R

  2. 出现界面之后,选择 Utilities menu 中 Terminal 。

  3. 在Terminal 中输入 csrutil enable 打开 SIP。

更新截图:

 


酷毙

雷人

鲜花

鸡蛋

漂亮

最新评论

(200字以内)
验证问答 换一个 验证码 换一个

  • 快毕业了,没工作经验,
    找份工作好难啊?
    赶紧去人才芯片公司磨练吧!!

最新评论

关于LUPA|人才芯片工程|人才招聘|LUPA认证|LUPA教育|LUPA开源社区 ( 浙B2-20090187  

返回顶部