注册 登录
LUPA开源社区 返回首页

yanqian的个人空间 http://www.lupaworld.com/?912 [收藏] [复制] [分享] [RSS]

我的博客

CentOS或RHEL上通过EPEL安装ejabberd可能遇到的问题

已有 1127 次阅读2013-9-5 18:57 |个人分类:自由企鹅|系统分类:IT技术

通过yum安装EPEL源中的ejabberd,可能会提示如下错误(我的环境是RHEL6.2):

Error: Package: libgsasl-1.4.0-4.el6.x86_64 (epel)
           Requires: libntlm.so.0()(64bit)

Error: Package: erlang-erts-R14B-04.2.el6.x86_64 (epel)
           Requires: libz.so.1(ZLIB_1.2.2)(64bit)

错误一可以直接去网上下载一个libntlm的包安装上就可以了,比如我下载的这个:libntlm-1.3-3.el6.x86_64.rpm
错误二虽然看上去要安装相对旧的zlib包,但是直接安装RHEL/CentOS 6.4中的zlib包也可以的,比如我安装的是:zlib-1.2.3-29.el6.x86_64.rpm,因为它也提供了“ZLIB_1.2.2” symbol,具体可以用readelf命令查看。

评论 (0 个评论)

facelist

您需要登录后才可以评论 登录 | 注册
验证问答 换一个 验证码 换一个

关于LUPA|人才芯片工程|人才招聘|LUPA认证|LUPA教育|LUPA开源社区 ( 浙B2-20090187 浙公网安备 33010602006705号   

返回顶部